OpenCL Performance MacBook Pro

Announcement of new releases, bugs, support, suggestions
Post Reply
Rainy
Posts: 3
Joined: 12.07.2021 20:10

OpenCL Performance MacBook Pro

Post by Rainy »

Hi all,

as a newbe at Helicon Focus I played around with the program and was quite surprised regarding the integrated benchmark results.

According to the Upload Results I got three different values:
  • AMD Radon Pro 560X Compute Engine:
Performance: 25.80 seconds (81,49 MPixel/s), Transfer Speed 5855.42 MiB/s
  • Intel (R) UHD Graphics 630
Performance: 25.90 seconds (81.18 MPixels/s), Transfer Speed 4578,44 MiB/s
  • No OpenCL acceleration:
Performance 20.97 seconds (100.28 MPixel/s)

Normaly, I'd expected the AMD GPU ways faster than the Intel GPU, which I'd expect somewhat faster than the CPU, but in that case, I'm quite unsure if it wouldn't be a better idea to disable OpenCL acceleration on that specific system.

What's very interesting, too is the fact, that my old MacPro - with a Nvidia Geforce Titan X show's nearly same results regarding OpenCL which is really surprising for me - as other programs like Davinci Resolve act ways faster on the Titan X....
Attachments
AMD RadeOn Pro 560X
AMD RadeOn Pro 560X
Bildschirmfoto 2021-07-12 um 20.05.05.png (108.96 KiB) Viewed 269 times
Intel(R) UHD Graphics 630
Intel(R) UHD Graphics 630
Bildschirmfoto 2021-07-12 um 20.03.30.png (109.54 KiB) Viewed 269 times
No OpenCL acceleration
No OpenCL acceleration
Bildschirmfoto 2021-07-12 um 20.01.49.png (111.91 KiB) Viewed 269 times
User avatar
Catherine
Posts: 596
Joined: 29.04.2019 22:38

Re: OpenCL Performance MacBook Pro

Post by Catherine »

Hi,

We have a number of benchmark results reported by users for AMD Pro 560X, ranging from 75 to 250. The majority of the results are in the 130-140 range, which is more that you've got, but still quite low compared to the CPU score. It is what it is, this is not a powerful GPU, and the transfer speed of 5800 MiB/s is lower than what it should be with PCI-Express x16 3.0 (9000-11000 MiB/s), this also impacts the total score.

81 is a reasonable score for UHD 630. The majority of the results in our database are around 90, but this is negligible difference that could be down to thermal performance of your laptop (the higher the GPU temperature is - the lower the GPU clock).

Titan X should indeed be faster, what transfer rate are your getting with it?
Rainy
Posts: 3
Joined: 12.07.2021 20:10

Re: OpenCL Performance MacBook Pro

Post by Rainy »

Hi Catherine,

the Titan X isn't as fast as expected....

According to Helicon Focus, it gives rates of 145.54 MPixel/s :(
TitanX MacOS .jpeg
Titan X
(238.43 KiB) Not downloaded yet
What's interesting in that case is the fact, that the GPU makes no noise at all. Normaly, when drawing high GPU-power, the fans get really very noisy/loud.

And additionally: even though I run a GPU Test, the CPU load is very high if you keep in mind that the system is powered by a dual XENON hex-core.
TitanX MacOS CPU-Load.jpeg
CPULoad while running GPU-Test
(524.84 KiB) Not downloaded yet
I guess, it is like it is - I have to accept. If you want to, you may close/remove this issue.

Kind regards
Last edited by Rainy on 16.07.2021 23:20, edited 1 time in total.
User avatar
Catherine
Posts: 596
Joined: 29.04.2019 22:38

Re: OpenCL Performance MacBook Pro

Post by Catherine »

Hi Rainy,

The transfer speed in your benchmark is about 3 times lower than it should be, it accounts for a lot of GPU under-utilization. This indicates a problem with PCI-Express link speed, a hardware issue.

The CPU spike at the beginning of the benchmark is perfectly normal, it's the preparation of the test images. This phase does not affect the benchmark score.
Alnitak
Posts: 4
Joined: 15.04.2018 16:23

Re: OpenCL Performance MacBook Pro

Post by Alnitak »

Something is broken with the latest version of either Helicon Focus or the MacOS and Helicon Focus.

I have two Mac Pros and I just got the new Radeon Pro W6800X Duo MPX module. I wanted to see how fast it would be and to my surprise the benchmark score was quite low. WAY below the other scores for Radeon 6800X cards. So I went and checked on my other Mac Pro with the older (but still very powerful) Radeon Pro Vega II cards--and it also is getting low scores--and much lower than the last time I checked.

I am pretty sure the last time I checked the benchmarks I was on the previous version of MacOS--both machines I've tested are on 11.5.2 as of today.

Something is broken right now with HeliconFocus and MacOS, maybe it's a driver issue with OpenCL and MacOS 11.5? My Radeon Pro Vega II MPX cards used to get a score in the mid 600's--now they get score that's in the mid 300's. The W6800X Duo is getting around 700-750, much lower than the 1000-2000 range I see listed for other 6800 cards.
Post Reply