Page 1 of 2

I can't get Helicon Focus to start

Posted: 22.05.2007 05:33
by FredT
I downloaded the Mac version of Helicon Focus to try it out. I'm running Mac OS 10.4.9 on a Powermac G5 dual. Each time that I try to run the program, it fails to start with the message "The application Helicon Focus quit unexpectedly.". Any hints as to what my proble is?

Posted: 22.05.2007 05:39
by Ariel
Are you using the correct version for intel or PPC?

Posted: 22.05.2007 07:09
by FredT
Yes, get info shows Kind: Application (PowerPC).

Posted: 22.05.2007 23:13
by FredT
Here's my theory as to what the problem is:

I downloaded the "Intel" version and looked at the application file. The file size is identical for both versions, and the package contents likewise are the same. I am guessing that the "Intel" version has been attached to both of the download links. Do the developers check in to these forums? I have not gotten a response to a direct email.

Posted: 22.05.2007 23:39
by Ariel
Could be. If it would be universal binary format (is that what it's called?), then I guess there could be only one file for both types of macs.

Dan Kozub is the main guy making the program, and most of the time he frequents this forum, but sometimes he's away for some time.

The download links do have different file names, but maybe there was an accidental switch of the contents? The file for Intel macs works just fine.

Posted: 23.05.2007 01:44
by FredT
Thanks Ariel. I'll just have to wait for Dan to check in. In the meantime I'm trying it out on my wife's Macbook, though she doesn't give me much time on it. :(

Posted: 24.05.2007 08:39
by Dan Kozub

IntelMacs work fine with the mac binaries. Intel version only has a little add on to fix OS bug when opening 16 bit images.

The actual problem is in compatibility with 10.4.9 version.

This version may help to solve the problem:

Posted: 24.05.2007 15:58
by FredT
Hi Dan,

I downloaded HeliconFocus3513 and tried running it on my G5, but it still has the same problem and won't start. :(

Is there anything else I should try?

Posted: 25.05.2007 10:55
by Dan Kozub

Posted: 25.05.2007 15:56
by FredT
Hi Dan,

Unfortunately 3514 has the same problem as the others.

Posted: 25.05.2007 16:32
by Dan Kozub
Can you contact me at, I will send you new version as soon it is ready.

Posted: 27.05.2007 15:08
by fzf5bl
Im having the same type problem on my PC it worked this morning one time after that I could not get it started I just downloaded the latest version and the samething happened.


Posted: 29.05.2007 11:19
by Dan Kozub

Here is the version which should start on 10.4.9

Slightly updated version will be published in a few days. We close to locating the bug.

unexpected quit

Posted: 28.11.2007 19:33
by tonysweet
Yep, the same thing here, but I've got OSX 10.4.11 with no problem.
The issue I'm currently having in opening in Leopard v10.5. That's where I get the immediate quitting upon opening.
I sent an email a couple of months ago on this and was assured there would be an upgrade.

All other software and plug ins that I use have been updated to work with Leopard, except for Helicon Focus. I'm a little disappointed in the sluggish response and am fortunate to have held back one of our computers from going to Leopard so that I can still work on a book project using Helicon. I would have been up the creek if I went to Leopard on all of our computers.

We're looking forward to the fix with some anticipation for sure.

Posted: 29.11.2007 07:44
by Ariel
I think they're working on a Leopard compatibility update. It would be nice if the HF releases would be in sync with Windows/Mac. Meanwhile, if you have a Windows license, you could try installing XP on bootcamp if you really need Helicon Focus now?