Page 1 of 1

Problems with Canon 90D

Posted: 10.02.2020 22:32
by Roobarb
I'm having trouble with Helicon Remote and my Canon90D both on the PC version and mobile app which both behave in the same way.
PC is Windows 10 x64, Remote V3.9.10W
Mobile is Android 10, Remote V3.9.10

Once connected, the program will mostly crash immediately losing connection with the camera.
If it does stay connected, then tap to zoom doesn't behave correctly and always zooms to the same spot at the top of the frame, aabout 1/3 of the way in from the top left corner.

I did submit a ticket and it was suggested to set the camera to JPG, then switch to RAW once connected, but this didn't help, so I submitted a bug report from within the app but didn't hear back, so posting here in case there are any suggestions.

I'm wondering if it's a camera setting causing this; for info I set the camera to single point AF, manual exposure, single drive, image review off, AF servo disabled.

I also use Remote with my Canon 760D and it works flawlessly, but it would be nice to be able to use either camera if possible.
I'm open to any suggestions on what to try or hear from other 90D owners who are having success to compare settings.

Re: Problems with Canon 90D

Posted: 14.02.2020 19:25
by Catherine
Sorry for not getting back to you on your bug report.

It's odd that the problem with zoom wasn't caused by raw image format because the symptoms match exactly, and it's the only known cause for this.
When you say that the program crash, do you mean that it literally stops running and disappears from the screen, or does something else happen?
Could you please try the latest beta version of Helicon Remote and let us know whether the problem is still there?

Re: Problems with Canon 90D

Posted: 14.02.2020 19:28
by Roobarb
It varies, either a crash with the program still open but unresponsive with a message about submitting a bug report, or on mobile occassionally completely exits and won't restart until it has been force closed.

I'll try out the beta and let you know how I get on, thanks :)

Re: Problems with Canon 90D

Posted: 14.02.2020 23:52
by Catherine
Roobarb wrote:
14.02.2020 19:28
a message about submitting a bug report
Please do send the report if you get the same in the beta.

Re: Problems with Canon 90D

Posted: 15.02.2020 00:28
by Pyonker
I can't get my 90D to connect at all with wifi or blue tooth to my MAC or my iPhone.
It shows the network on the camera but fail to connect. Would canon's EOS Utility interfere?

Re: Problems with Canon 90D

Posted: 15.02.2020 01:18
by Catherine
It would interfere but the symptoms would be different, sounds like you didn't get the far. Don't try Bluetooth, only Wi-Fi. Please follow this guide: ... n_built-in

Re: Problems with Canon 90D

Posted: 15.02.2020 14:41
by Roobarb
Hi Catherine,

I've just tried out the beta on PC and it doesn't crash on connecting however, click to zoom still zooms into a point at the top of the image, about 1/3 in from the left as before.
Autofocus doesn't update in the live view although I do hear the confirmation beep from the camera suggesting it did receive the focus command and attained it.

If the camera is powered down, then powered back on, then the toolbar greys out and becomes unresponsive. Restarting the app re-enabled the toolbar

Re: Problems with Canon 90D

Posted: 18.02.2020 09:45
by Dresli
I have a similar problem with zooming when shooting only RAW.
When changing the shooting mode to RAW+JPG or only JPG zooming works fine.
RAW files appear with the extension .dat and images do not show.
In Bridge or Finder changing the extension to .cr3 makes images appear as RAW files that can be worked with.

Re: Problems with Canon 90D

Posted: 18.02.2020 22:52
by Roobarb
Thanks for the info Dresli.

Confirming from a quick test running the V4 beta on my desktop PC that touch to zoom appears to work correctly if set to RAW+JPG, and doesn't work correctly if set to RAW only.

Probably tomorrow night I will re-test this on my laptop which still has V3.9 installed.

Mobile app on Android doesn't touch to zoom correctly when set to RAW or JPG only, will test RAW+JPG, also on Anroid the live view lags badly and the app disconnects/crashes.

I haven't confirmed the file extension issue as I use the laptop to capture, save to camera then transfer from card to desktop for editing.

Re: Problems with Canon 90D

Posted: 21.02.2020 08:00
by Catherine
Sorry for replying late. As I mentioned a few messages earlier, both the beta (v. 4.0.0) and the release version (3.9.10) may have problems with zoom and autofocus if only raw is selected, although I'm recalling we did include a workaround for this in the beta, which apparently didn't work for you. We will re-test.

Of note: it only matters what image format is selected when the connection is initialized. After the cameras takes a shot (as it does automatically every time while connection is being established), you can then safely switch to raw.

Additionally, we have found another issue just yesterday that causes the beta to zoom and autofocus incorrectly regardless of the selected image format. It only affects the beta, and probably only on Windows and not Mac, and it doesn't depend on the selected image quality.

I don't know why the Android app wouldn't zoom correctly with JPEG only, could you reproduce the problem and send a bug report (menu - Feedback- Report a bug)? And another report while the app is lagging will be useful as well. You can unplug the camera after it lags for a bit, that should stop the lags so you can send the report more easily. Just make sure not to restart the app or the info about the problem will be lost and the report won't show anything useful.

And yes, v. 3.9.10 saves raw files with ".dat" extension, we'll patch that soon in an update.

Re: Problems with Canon 90D

Posted: 22.02.2020 22:40
by Roobarb
Just reporting back in.
I've not yet tested on the mobile app as I'm still testing and playing with the PC app.
Confirm that V3.9 does tap to zoom correctly on V3.9 if set to RAW+JPG.

However, I've just been doing a test test stack of 100 or so shots and the program timesout at 60 shots taken. Assuming that this was due to insufficient battery, I replaced with a fresh battery and repeated the stack with the same result. I have sent a bug report in from the program.

Also to note that after this, turning the camera off I see a message on the camera screen (Saving 2 images). This message stays on the screen until I unplug the USB cable, then goes down to 1 image remaing before fully powering off.

Hope this info and bug report proves helpful; I will report back on the mobile app once I get a chance to test that through. I'm going to now repeat this stack using the Canon760D to compare results.

Edit to add: 760D just went through the stack without any issues.

Re: Problems with Canon 90D

Posted: 04.03.2020 00:38
by Catherine
A late reply, but I believe we've already responded to your bug report on the same matter in a more timely fashion. Thanks for letting us know about the problem. I hope we'll be able to provide you the new beta version by next week, and hopefully it will solve the problem. We'll see.